Please subscribe to the official Codeforces channel in Telegram via the link: https://t.me/codeforces_official. ×

KlRlTO's blog

By KlRlTO, 10 months ago, In English,

Hello Codeforces!

I'm using Dev C++ IDE, and installed only c++11. Can anyone help me to install c++17 or c++14 ( best of this)?

 
 
 
 
  • Vote: I like it  
  • -4
  • Vote: I do not like it  

»
10 months ago, # |
Rev. 2   Vote: I like it 0 Vote: I do not like it

Dev C++ has really a bad editor, install codeblocks (if I'm not mistaken here is c++17).

»
10 months ago, # |
Rev. 3   Vote: I like it +11 Vote: I do not like it
  1. learn the difference between ide, programming language and compiler
  2. assuming you are using Windows choose a GCC package with suffiently new GCC version. Most likely mingw-w64 tdm-gcc or cygwin.
  3. install it
  4. configure your ide to use the compiler you just installed
  5. configure your ide to pass the required flags to enable the c++ language version you chose