Possible bug in checker when running PyPy3

Revision en1, by aberent, 2021-06-21 13:29:18

Is the checker occasionally failing to detect that a test has completed, and so giving a TLE?

In Codeforces round 727 problem C, when the system tests were run, I got TLE on my submission on test 18. Looking at the results my code printed the result before getting the TLE, and my code should exit immediately after printing the result. At first I assumed that I was just unlucky, and my code had taken precisely one second to run, so had been stopped just before exiting.

After the contest I tried modifying my code in various ways to speed it up, for example https://codeforces.com/contest/1539/submission/120193428 and https://codeforces.com/contest/1539/submission/120195587. In all cases I got exactly the same result; my code printed an answer but still got a TLE. It seems extremely unlikely that every single version of my code would take precisely 1 second to run.

To confirm this, I tried running my most recent version under Python3 instead of PyPy3. This is normally slower, but on this occasion passed all tests without any TLEs.

Tags #bug, checker, #pypy3


  Rev. Lang. By When Δ Comment
en2 English aberent 2021-06-21 13:31:55 61
en1 English aberent 2021-06-21 13:29:18 1207 Initial revision (published)